MassGIS logo

MassGIS maintains a comprehensive, statewide database of spatial information for mapping and analysis supporting emergency response, environmental planning and management, transportation planning, economic development, and transparency in state government operations.

Visit the MassGIS website

Browse all MassGIS data layers

Other Access

The information on this page (the dataset metadata) is also available in these formats.

JSON RDF

via the DKAN API

MassGIS Data: Digital Terrain Model (DTM) Files

April 2003
Digital Terrain Model of land surface point elevations for creating surface models
Download these DTM files (337 MB .zip file)
Digital terrain models are representations of land surface point elevations. They are used as input for the generation of surface models and contours or the orthorectification process of aerial photography. The DTMs available from MassGIS were produced for the processing of the 1:5,000 Black and White Digital Orthophoto images and their related data layers (Elevation Contours , Elevation Points , and Topographic Breaklines). The DTM data points were collected on analytical stereoplotters at a sufficient density to support generation of 3-meter contours conforming to the National Map Accuracy Standards (+ or - 1.5 meters). Mass points were collected along parallel scan lines 75 meters apart at variable density as a function of the topography and other ground features. Spot elevations at summits and in depressions and breaklines along significant linear features were also collected. Distinctions between "hard" and "soft" breaklines were established and standardized to facilitate the generation of contours. These DTMs are stored in ASCII text format and contain five columns of data:
  • "X" and "Y" horizontal coordinates in the NAD83 Massachusetts State Plane coordinate system;
  • "Z" elevation values in meters (NAVD88);
  • a keyword used by the Arc/INFO software for the production of triangulated irregular networks (TINs):
    • SOFT = point is part of a soft breakline
    • HARD = point is part of a hard breakline
    • MASS or LAKE = mass point (not part of a breakline);
  • a numeric value that indicates the the type of point:
    • 1 = start of a breakline (start node)
    • 2 = vertices of a breakline
    • 4 = end of a breakline (end node)
    • 5 = mass point (not part of a breakline)
They are tiled by the Orthophoto Quad Index. (Note that the DTMs for Martha's Vineyard and Nantucket use the OQISLE Index SHEET-IDs pdf
format of Ortho Island Index
; the mainland tiles use the OQMAIN mainland SHEET-IDs pdf
format of ix_oq.pdf
file size 4MB ). The naming convention for the files is the Orthophoto Index SHEET-ID and a .dtm extension. The SHEET-ID is the first 3 digits of the XY coordinate pair for the lower right corner of each 4-kilometer-square cell in the Index. The points in each DTM overlap the edges of the OQ Index tile by 5-10 percent in all directions.

DTMs for Martha's Vineyard and Nantucket contain X and Y coordinates referenced to the NAD83 Massachusetts Island Zone (Fipszone 2002) coordinate system and use the OQISLE index SHEET-IDs. X and Y coordinates for the rest of the state are referenced to the Mainland Zone (Fipszone 2001).

Using the Data

To produce elevation rasters, one may take these text files and load into software that can convert "raw" XYZ data to a raster format. Note that these are not in the format of a text file that may be used in the ASCIIGRID command in ArcInfo Workstation. One method is to load the file into Microsoft Excel, delete the last two columns, format the remaining three as numbers with the decimals places preserved, add a column header row (for field names, such as "X", "Y", "Z") and save in CSV or dBase 4 format. (To ensure that the space-delimited data are stored in separate columns, open Excel first and then choose Data > Get External Data > Import Text File. Select the .dtm and in the Text Import Wizard that appears, click the 'Delimited' radio button in the first screen, then check off 'Space' in the second.) Bring the .csv or .dbf file into ArcMap and choose to display XYZ data. This will create an "event theme" of points. Convert/export this point theme to a point shapefile and, using the Spatial Analyst extension, convert the point layer to a raster (image or grid) with the 'Interpolate to Raster' tool (be sure to choose the Z-value field, as the dialog may default to the X-value field). In ArcGIS 10, use the Toolbox tool Spatial Analyst Tools > Interpolation > Kriging (or another tool there to use another method). Yet another approach is to parse the original DTM with scripts and use ArcInfo Workstation to create a TIN (taking advantage of the breakline information), which then may be used to create a raster (lattice). MassGIS has awk scripts and AML code for this. If interested in receiving copies please contact michael.trust@state.ma.us.

Maintenance

This datalayer is maintained by MassGIS. For related datalayers see:

Last Updated 10/5/2017

Items

Contributor
Modified Date
2017-11-21
Release Date
2017-11-16
Identifier
6834b2d2-a007-48aa-8438-8ca5a9d5ccd8
Spatial / Geographical Coverage Location
Massachusetts
License
Author
MassGIS
Contact Name
MassGIS
Contact Email
Public Access Level
Public
Data Quality
False
Language
English (United States)